reading the description of the new LRU cache in the "What's new in 3.2"
document now, I got the impression that the hits/misses attributes and the
.clear() method aren't really well namespaced. When I read
it's not very obvious to me what happens, unless I know that there actually
*is* a cache involved, which simply has the same name as the function. So
this will likely encourage users to add a half-way redundant comment like
"clear the cache" to their code.
What about adding an intermediate namespace called "cache", so that the new
operations are available like this:
It's just a little more overhead, but I think it reads quite a bit better.