
[nnorwitz@users.sourceforge.net]
Modified Files: _randommodule.c Log Message: Try to get compilation working for cygwin
Index: _randommodule.c
And then, for example, before:
! PyObject_GenericGetAttr, /*tp_getattro*/
and after:
! 0, /*tp_getattro*/
followed by:
+ Random_Type.tp_getattro = PyObject_GenericGetAttr; + Random_Type.tp_alloc = PyType_GenericAlloc; + Random_Type.tp_free = _PyObject_Del;
in the module init function. Please don't make this kind of change -- it makes the code so much harder to follow. If this is needed for Cygwin, then, e.g., do #define DEFERRED(x) 0 /* some boxes can't resolve addresses at compile-time */ and make the "after" line DEFERRED(PyObject_GenericGetAttr), /*tp_getattro*/ IOW, the type slots should be readable on their own, as a static unit.