Steven D'Aprano wrote:
On Sun, 14 Jun 2009 10:40:53 am Greg Ewing wrote:
Zooko Wilcox-O'Hearn wrote:
- Add a "st_crtime" field which gets populated on filesystems
(Windows, ZFS, Mac) which can do so.
"crtime" looks rather too similar to "ctime" for my liking. People who think that the "c" in "ctime" means "creation" are still likely to confuse them.
Why not give it a more explicit name, such as "st_creationtime"?
My this bike-shed looks a bit greenish. How about: creation_time or, at least, st_creation_time
Speaking as somebody who thought the c in ctime meant creation, I'm +1 on this proposal with Greg's modification.
--Scott David Daniels Scott.Daniels@Acm.Org