On Wed, Sep 21, 2011 at 11:02 AM, Stefan Krah email@example.com wrote:
Ezio Melotti firstname.lastname@example.org wrote:
+@unittest.skipIf(not have_long_long, 'need long long support')
I think this would read better with skipUnless and s/have/has/:
@unittest.skipUnless(HAS_LONG_LONG, 'need long long support')
skipUnless() is perhaps a bit cleaner, but have_long_long is pretty established elsewhere (for example in pyport.h).
I agree with Stefan on the have_long_long part. This is what is used in the array module code, struct, ctypes, etc ... (via pyport.h as Stefan mentioned). As for the unless/if, I am OK with the 'if'. 'unless' always causes a double-take for me. Personal preference I guess.