On Feb 17, 2008 2:42 PM, Raymond Hettinger <python@rcn.com> wrote:
There are some modules like Decimal that make a promise to run on earlier
versions of Python.  In those cases only the first change (backwards compatible)
should be made.  Our 5,000 line Decimal package will need to wait for 3.0 to
use the except/as form :-(

Not a problem.  Decimal doesn't use "except Exception, err" anywhere
in those 5000 lines, as far as I can tell! :-)

Mark