In retrospect, it should have been called sys._setdefaultencoding(). That sends an extra signal that it's not meant for general use.
Crazy idea: how about mutating it into sys._setdefaultencoding rather than deleting it?
Please don't post crazy ideas unless you really mean them.
This specific crazy idea must be rejected; it would break backwards compatibility, for no good reason.