I don't mind iterdir() and would take it :-), but I'll just say why I chose the name scandir() -- though it wasn't my suggestion originally:
iterdir() sounds like just an iterator version of listdir(), kinda like keys() and iterkeys() in Python 2. Whereas in actual fact the return values are quite different (DirEntry objects vs strings), and so the name change reflects that difference a little.
I'm also -1 on windows_wildcard. I think it's asking for trouble, and wouldn't gain much on Windows in most cases anyway.
On Thu, Jun 26, 2014 at 7:43 PM, Ethan Furman firstname.lastname@example.org wrote:
On 06/26/2014 04:36 PM, Tim Delaney wrote:
On 27 June 2014 09:28, MRAB wrote:
Personally, I'd prefer the name 'iterdir' because it emphasises that it's an iterator.
Exactly what I was going to post (with the added note that thee's an obvious symmetry with listdir).
+1 for iterdir rather than scandir
Other than that:
+1 for adding [it] to the stdlib
+1 for all of above
Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/benhoyt%40gmail.com