July 26, 2007
2:11 a.m.
Raymond Hettinger wrote:
In the case of iter(collection), I prefer the current wording because the target object need not support __iter__, it is sufficient to supply a sequential __getitem__ method.
Seems to me that should be included in the definition of an iterable -- i.e. anything for which iter() works is an iterable. -- Greg