
Oct. 20, 2003
12:34 a.m.
Sean Ross <seandavidross@hotmail.com>:
# (1) without parentheses: B(y) for y in A(x) for x in myIterable
Er, excuse me, but that had better *not* be equivalent to
# (2) for clarity, we'll add some optional parentheses: B(y) for y in (A(x) for x in myIterable)
because the former ought to be a single iterator expression with two nested loops (albeit an erroneous one, since x is being used before it's bound). Greg Ewing, Computer Science Dept, +--------------------------------------+ University of Canterbury, | A citizen of NewZealandCorp, a | Christchurch, New Zealand | wholly-owned subsidiary of USA Inc. | greg@cosc.canterbury.ac.nz +--------------------------------------+