Python has always preferred full-word over old-school C/Perl/PHP-style abbreviated names. Clarity is paramount. (Or this whole discussion wouldn't even be happening.)

I think this is *more* of a zip_shortest than zip_strict, but since you can never have total clarity without a method name that doubles as a docstring, whatever works will work as long as it's documented.


On Wed, May 20, 2020 at 3:33 PM Joseph Jenne via Python-Dev <> wrote:

I'd like to suggest "len_eq" as a short but (rather) self-explanatory option.