Oct. 29, 2001
7:22 p.m.
"TP" == Tim Peters <tim.one@home.com> writes:
TP> BTW, and not meaning to hijack your PEP <wink>, should TP> dict.update() accept such an argument too? I didn't add it TP> because TP> d.update(dictionary(such_an_argument)) TP> seemed "almost good enough". Agreed. But either way, I still there there is utility in a dict comprehension. TP> BTW2, are we going to rename "dictionary" to "dict" before TP> 2.2b2? Before 2.2, "dict" was universally used on c.l.py to TP> mean dictionary, and I'm at least +0 on adopting that for TP> official 2.2 use. I wouldn't keep them both though. Use one or the other. -Barry