On 27.06.2014 03:50, MRAB wrote:
On 2014-06-27 02:37, Ben Hoyt wrote:
I don't mind iterdir() and would take it :-), but I'll just say why I chose the name scandir() -- though it wasn't my suggestion originally:
iterdir() sounds like just an iterator version of listdir(), kinda like keys() and iterkeys() in Python 2. Whereas in actual fact the return values are quite different (DirEntry objects vs strings), and so the name change reflects that difference a little.
The re module has 'findall', which returns a list of strings, and 'finditer', which returns an iterator that yields match objects, so there's a precedent. :-)
A bad precedent in my opinion though -- I was just recently bitten by that, and I find it very untypical for python.