Jan. 7, 2004
5:52 p.m.
Josiah Carlson wrote:
Using min and max to be the smallest and largest objects, as well as being functions that can be called to find the smallest or largest value in a sequence, seems to be intuitive.
Only in the sense that "min" and "max" are intuitive *names* for these objects, to English speakers. On the other hand, I wouldn't mind having "min()" and "max()" (currently TypeErrors) return the minimal and maximal objects. Cheers, Evan @ 4-am