On Wed, Aug 19, 2009 at 2:20 PM, Eric Smith <eric@trueblade.com> wrote:
I think using .network and .broadcast are pretty well understood to be the [0] and [-1] of the network address block. I don't think we want to start creating new terms or access patterns here.

+1 on leaving .network and .broadcast as-is (including returning a IPvXAddress object).

-1.  I think 'network.number' or 'network.zero' is a lot clearer than 'network.network'.  Maybe '.broadcast' would be okay, as long as it can be adjusted for those unusual, or maybe even only hypothetical, networks where it is not the [-1].