That's just a flaming-sword thread but I want to mention it nonetheless :-)
Basically I propose getting rid of __future__._Feature.getMandatoryRelease() in favour of __future__._Feature.mandatory. That's backwards compatibile and much more pythonic. Getters/Setters are considered unpythonic and the getting rid of all that Java-like naming sounds like a good idea to me :)
If threading/processing gets a pep8ified API with 2.6, why not __future__?
Proposed patch: http://paste.pocoo.org/show/64512/