I used the same convention as you, and my vote was thus as the record will show (note the negatives):
zip(strict=True) +1
itertools.zip_strict() +0
zip(mode='strict') -1
zip.strict() -1
And I stand by that: I think Python would be better off without the 3rd and 4th option, even if no alternative was implemented. To go to one of the examples (not exactly, you'll understand why...) was given in the other thread: if we suggested
asdfasfa.kjllasdfa.asdf()
as the name(space) for the zip(strict=True) functionality, I would:
- vote -1 (or hyperbole -10^googol)
- still use the feature when I wanted to use 'zip(strict=True)'
- think Python would be a worse programming environment for allowing this to be introduced
Obviously the 3rd and 4th option are not as insane/illogical as the above example (apologies, I would attribute, but the nature of this example makes it hard for me to search for it!) but I do not like functionality exposed in this way and I think the lack of this functionality in the stdlib does not weigh up against the precedent/bad example this would set.
You, and anyone else, can and some definitely will disagree with me but it's my vote, and I don't think it matters that much anyway:
There has been a lot of discussion, and these straw polls, from my limited understanding, are often taken to see whether there is a clear consensus to short-circuit/end the discussion, I would say in this case it has shown inconclusiveness, which is fine, the final decision on this PEP will (fortunately) not be decided by our votes.
I understand your 'pain' Stephen: I still think it is weird that people on these lists don't want "for x in some_iterable if x is not None:" as valid syntax, but I have, almost, made my peace with it.