
4 Aug
2021
4 Aug
'21
3:31 p.m.
On Tue, Aug 3, 2021 at 7:54 PM Ethan Furman ethan@stoneleaf.us wrote:
I would rather keep `bchr` and lose the `.fromint()` methods.
I would prefer to only have a bytes.byte(65) method, no bchr() built-in function. I would prefer to keep builtins namespace as small as possible.
bytes.byte() name is similar to bytes.getbyte(). I cannot find "int" in the name of other bytes methods.
some_var = bytearray(bchr(65)) vs some_var = bytearray.from_int(65)
bytearray(bchr(65)) sounds less efficient.
Victor
--
Night gathers, and now my watch begins. It shall not end until my death.