I agree to make PendingDeprecationWarning an alias to DeprecationWarning. I never liked "PendingDeprecationWarning" name, it's way too long to type :-D
Le ven. 22 mars 2019 à 03:45, Inada Naoki firstname.lastname@example.org a écrit :
I want to stop using PendingDeprecationWarning for new deprecation.
I'm fine with that.
More aggressively, I want to remove PendingDeprecationWarning class, and `PendingDeprecationWarning = DeprecationWarning` for backward compatibility.
I'm not sure that I understand well. Do you want to remove the PendingDeprecationWarning builtin symbol, or just make it an alias to DeprecationWarning.
I'm fine with "PendingDeprecationWarning = DeprecationWarning".
IMHO your email title is misleading. You don't want to *remove* PendingDeprecationWarning, you only want to make it an alias to DeprecationWarning, right? In term of backward compatibility, it's very different :-)