+1 for scandir. -1 for iterdir(scandir sounds fancier). -99999999 for windows_wildcard.
Tim Delaney firstname.lastname@example.org wrote:
On 27 June 2014 09:28, MRAB email@example.com wrote:
Personally, I'd prefer the name 'iterdir' because it emphasises that it's an iterator.
Exactly what I was going to post (with the added note that thee's an obvious symmetry with listdir).
+1 for iterdir rather than scandir
Other than that:
+1 for adding scandir to the stdlib -1 for windows_wildcard (it would be an attractive nuisance to write windows-only code)
Python-Dev mailing list Python-Dev@python.org https://mail.python.org/mailman/listinfo/python-dev Unsubscribe: https://mail.python.org/mailman/options/python-dev/rymg19%40gmail.com