Steve Holden wrote:
Greg Ewing wrote:
Mike Orr wrote: Having said that, I can see there could be an element of confusion in calling it "join".
Good point. "relativise" might be appropriate, though something shorter would be better.
The term used in many languages for this sort of operation is "combine". (See .Net System.IO.Path for an example.) I kind of like the term - it implies that you are mixing two paths together, but it doesn't imply that the combination will be additive.