Sridhar Ratnakumar <sridharr <at> activestate.com> writes:
On 09-06-23 02:57 AM, Nick Coghlan wrote:
Something like DistributionDirectoryMap should cover it.
You could probably get away with shortening "Directory" to "Dir" in the class names though:
'Map' reminds me of an associated hash (or is it the actual map?).
Good thing, because it is a dict subclass if you read the PEP :)
+1 with Nick's proposal.
(we are good at finding bikesheds everywhere aren't we?)