On Mon, Feb 11, 2002 at 02:52:30PM -0600, Skip Montanaro wrote:
The only thing I'd change is that if PyDict_GetItem_Fast is a macro that only works for interned strings, I'd change its name to reflect its use: PyDict_GET_ITEM_INTERNED or something similar.
One other naming change is to prefix PyDict_GetItem_Fast2 with an underscore, since the comments about its use make it clear that it's an internal function.
Done and up on the same URL.
PyDict_GetItem_Fast -> PyDict_GETITEM_INTERNED PyDict_GetItem_Fast2 -> _PyDict_GetItem_Interned