May 18, 2011
7:47 p.m.
On 18.05.2011 21:06, "Martin v. Löwis" wrote:
Note that the more common idiom (not that I can measure it, mind) when dealing with byte strings is something analogous to
if my_byte_string[i:i+1] == b'x':
rather than
if my_byte_string[i] == 170:
FWIW, Another spelling of this is
if my_byte_string[i] == ord(b'x')
From a readability point, it's in the same category as the first one, but less twisted.
Probably more twisted: if my_byte_string[i] == b'x'[0]: :) Georg