I'm +0 on this (reasons below), but since Guido already said no:
I find this function pretty useful, as it serves to collapse ugly code, and I hate ugly python code. However, the name sucks. With your changes, 'divmod' doesn't describe it anymore.
So I suggest you come up with a better name and offer it as a contribution to, say, the math module. In that case I would prefer to have the reverse function too.
(The fact that using it with 2 args is equal to calling divmod is at most a funny fact. As Guido says, growing the library = good; growing the language = questionable)