Raymond Hettinger wrote:
On a separate note, I also propose that __exit__() be renamed to __leave__(). The enter/leave word pairing are a better fit in standard English:
I tend to associate leave with leaving, and leaving with arriving.
I didn't even think the __enter__ / __exit__ names were an issue. <shrug>
Then again there's alway __premanage__ and __postmanage__. That fits Nicks requirement for visual pairing as they both start with 'p'. And then calling it a manager object fits very nicely too.
Hmmm, wonder if you could implement programs based on gant charts using nested manager objects? Would the nested managers be mid-level managers?
This might have some marketing appeal to large corporations. ;-)