On 09/11/2013 08:48 AM, Antoine Pitrou wrote:
Le Wed, 11 Sep 2013 07:48:56 -0700, Ethan Furman email@example.com a écrit :
Personally, I wouldn't mind having all four; for one thing, the name 'transformdict' would then be entirely appropriate. ;)
The key decoder function is quite useless since the original key is retained. As for the value encoder/decoder, I don't really see the point: just store whichever value you want to retrieve later. The main point of transformdict is that the *lookup* is done using a different key than the user-provided key.
Very good points. I am convinced.