Le 28/07/2011 11:28, Victor Stinner a écrit :
Please do keep the original implementation around (e.g. renamed to codecs.open_stream()), though, so that it's still possible to get easy-to-use access to codec StreamReader/Writers.
I will add your alternative to the PEP (except if you would like to do that yourself?). If I understood correctly, you propose to:
- rename codecs.open() to codecs.open_stream()
- change codecs.open() to reuse open() (and so io.TextIOWrapper)
(and don't deprecate anything)
I added your proposal to the PEP as an "Alternative Approache".