On 06/12/2010 21:02, Raymond Hettinger wrote:
On Dec 6, 2010, at 11:40 AM, Fred Drake wrote:
On Mon, Dec 6, 2010 at 2:21 PM, Raymond Hettinger firstname.lastname@example.org wrote:
We really ought to stop with the SafeFoo naming convention. It is only descriptive to the person who wrote the class or function, not to the user who will immediately wonder, "safe from what?"
Safe from bad vampire movies, of course!
I'd not recognize the current Safe* class names as a pattern; there are currently two in the py3k trunk:
configparser.SafeConfigParser -- very much a poor name xmlrpc.client.SafeTransport -- perhaps should have been SSLTransport or HTTPSTransport
I agree the "Safe" prefix isn't meaningful.
IIRC, pprint has a safe_repr() and string.Template has safe_substitute() and pydoc has a safe import.
Never new there was so much danger in the standard library :-)
What would you name those functions instead?
(SafeConfigParser is a naff name and only needed because ConfigParser is broken.)
Raymond _______________________________________________ Python-Dev mailing list Python-Dev@python.org http://mail.python.org/mailman/listinfo/python-dev Unsubscribe: http://mail.python.org/mailman/options/python-dev/fuzzyman%40voidspace.org.u...