On 27 June 2014 09:28, MRAB <python@mrabarnett.plus.com> wrote:
Personally, I'd prefer the name 'iterdir' because it emphasises that
it's an iterator.

Exactly what I was going to post (with the added note that thee's an obvious symmetry with listdir).

+1 for iterdir rather than scandir

Other than that:

+1 for adding scandir to the stdlib
-1 for windows_wildcard (it would be an attractive nuisance to write windows-only code)

Tim Delaney