Andrew Koenig wrote:
Lalo> I'm +0 on this (reasons below), but since Guido already said no: Lalo> I find this function pretty useful, as it serves to collapse Lalo> ugly code, and I hate ugly python code. However, the name Lalo> sucks. With your changes, 'divmod' doesn't describe it anymore.
Lalo> So I suggest you come up with a better name and offer it as a Lalo> contribution to, say, the math module. In that case I would Lalo> prefer to have the reverse function too.
If it helps, APL uses the names "base" and "represent" for these two functions.
I thought it used "radix" and not "base"?