Le 29/07/2011 19:01, Guido van Rossum a écrit :
I will add your alternative to the PEP (except if you would like to do that yourself?). If I understood correctly, you propose to:
- rename codecs.open() to codecs.open_stream()
- change codecs.open() to reuse open() (and so io.TextIOWrapper)
Ok, most people prefer this option. Should I modify the PEP to "move" this option has the first/main proposition (move my proposition as an alternative?), or can the PEP be validated in the current state?