On Wed, Jan 13, 2021 at 7:25 AM Serhiy Storchaka <storchaka@gmail.com> wrote:
12.01.21 22:38, Julien Palard via Python-Dev пише:
> During the development of cpython 3.10, Sphinx was bumped to 3.2.1.
>
> Problem is Sphinx 3 have some incompatibilities with Sphinx 2, some that
> we could work around, some are bit harder, so we may need to bump
> `needs_sphinx = '3.2'` (currently it is 1.8).

Sphinx version in the current Ubuntu LTS (20.04) is 1.8.5. Would not it
cause problems with builting documentation on Ubuntu?

Why can't contributors install from PyPI? The venv created by the Docs/Makefile does a pip install, so I don't see why what version of Sphinx is packaged via APT is a critical blocker in upgrading Sphinx.