On Thu, Mar 26, 2009 at 10:26 PM, Greg Ewing email@example.com wrote:
Guido van Rossum wrote:
I'll gladly take that as an added rationalization of my plea not to change datetime.
In the case of datetime, could perhaps just the module name be changed so that it's not the same as a name inside the module? Maybe call it date_time or date_and_time.
I don't think that's advisable ATM -- again, something we should have done for 3.0, but now it's too late.
I really don't want to set a trend where 3.1 is backwards incompatible with 3.0 *except* in cases where we were really planning to kill something in 3.0 and accidentally forgot to quite remove it completely (like cmp()).