On Fri, May 15, 2020 at 5:37 AM Chris Angelico <rosuav@gmail.com> wrote:
On Fri, May 15, 2020 at 7:23 PM Stephen J. Turnbull
<turnbull.stephen.fw@u.tsukuba.ac.jp> wrote:
> Chris Angelico writes:
>  > I don't like this term "converted".
> I refuse to die on that hill. :-)  Suggest a better term, I'll happily
> use it until something even better comes along.  Or I'll try to come
> up with a better one as I think about the documentation issue.

Unfortunately I don't have a really good generic term, but I would be
inclined to "get an iterator from" an object rather than "convert" it
to an iterator. It's still not a great term, but at least it allows
you to think about getting multiple iterators from the same thing,
even potentially getting different types of iterator.
Perhaps use the iter function name as the generic? "itered". As opposed to "iterated" or "iterated over".


"the statement below iterates over an iterator, itered from a sequence"