On Oct 9, 2012 1:12 AM, "Senthil Kumaran" <senthil@uthcode.com> wrote:
> > `p.pathjoin(q)`
>
> +1
>
> It is very explicit and hard to get it wrong.

+1

...and it's not _that_ long a name.  This would be a provisional module, so we could try the name on for size <wink> or hide it behind an operator later.

-eric