See my post a month ago (29 September) in the archive with links
to some related discussions. Subject "while: for the loop".
(I don't have access to the archive now so I can't link to the post)

One proposal was exactly about the "loop" keyword:

I was proposing "while" to replace  "while True". 
My opinion is that adding a new keyword just to replace
"while True:" would be too much, also it can cause
problems with syntax highlighting, some code analysis and
replacements if a variable "loop" is used. Since it was not
a keyword, the probability that someone had used such variable
can be significant.


On Sun, Oct 28, 2018 at 2:38 AM Juancarlo Añez <> wrote:

A `loop:` statement to replace `while True:` has probably been discussed at length more than once.

Does anyone keep links to the discussions?


Juancarlo Añez
Python-ideas mailing list
Code of Conduct: