On Thu, Nov 28, 2019 at 02:06:08PM +0400, Abdur-Rahmaan Janhangeer wrote:
> It's about ambiguity. Maybe loads is short for load string which in english
> is also a verb.
True. It took me a long time to stop getting confused between
pickle.load and .loads until I stopped reading it as "loads" and started
reading it as "load-s(tring)".
I agree with you that this is a sub-optimal naming convention, and we
would have been better if a different choice was made at the beginning.
But unfortunately it is a widely used naming convention:
* yaml (I think)
* and probably more
and not just in Python. But I agree with the others that the pain and
disruption from changing it is greater than the benefit. We all just
have to memorise that "loads" means "load-string" and not the present
tense of load.
Python-ideas mailing list -- firstname.lastname@example.org
To unsubscribe send an email to email@example.com
Message archived at https://firstname.lastname@example.org/message/FVP522GAT6EMIZP36BKRULCXCJCUEHCC/
Code of Conduct: http://python.org/psf/codeofconduct/