On 1/25/07, tomer filiba email@example.com wrote:
On 1/26/07, Collin Winter firstname.lastname@example.org wrote:
The "__getstate__" and "__setstate__" names don't really work for me either, especially since __setstate__ creates a new object, as opposed to changing the state of an existing object. Since this proposal is all about simplification, how about something like "__simplify__" and "__expand__", respectively?
well, i like __simplify__, but __expand__ seems wrong to me. some other suggestions i looked up:
__complicate__ (:-)) __rebuild__ __reconstruct__ (too long?) __restore__ (but that's semantically the same as __setstate__)
i'd vote for __rebuild__. any other ideas?
I like __rebuild__.