On Tue, Oct 9, 2012 at 12:12 AM, Paul Moore email@example.com wrote:
On 9 October 2012 00:19, Ryan D Hiebert firstname.lastname@example.org wrote:
If we want a p.pathjoin method, it would make sense to me for it to work similar to urllib.parse.urljoin
The parallel with urljoin also suggests that pathjoin is a better name than joinpath. But note that I've seen both used in this thread - there is obviously some level of confusion possible.
pathjoin is strikes well, if we are already accustomed with the term 'urljoin'.
Ryan - the protocols of those two joins will vary and should not be confused. Also pathjoin specifics would be listed in PEP 428.