I love the do_stuff if cond syntax in Ruby and in perl. It's very natural to real, much more to follow than if cond: do_stuff
I on the other hand hate that syntax and find it harder to read.
Why put the code out of sequence?
if read_this_1st: read_this_2nd()
vs. this that I think of as out of sequence order
read_this_2nd() if not read_this_1st
But still I don't think that it is enough to demand a language change.
Something near this is to have a default of none for
A if B else None
So we can ommit the else None part, but this goes against the explicit is better than implicit
Python-ideas mailing list -- firstname.lastname@example.org
To unsubscribe send an email to email@example.com://mail.python.org/mailman3/lists/python-ideas.python.org/
Message archived at https://firstname.lastname@example.org/message/WEK6CTGJGEBD6ROG5BASTJ6C43OKBTRE/
Code of Conduct: http://python.org/psf/codeofconduct/