Hello,

In Modules/main.c, wherever PyImport_ImportModule() is use, the variables (runpy and sys) are named as follows:

runpy = PyImport_ImportModule("runpy");    // line 265
sys = PyImport_ImportModule("sys");           // line 444

Can we also rename 'mod' to 'readline' for consistency in line 215?

PyObject *mod = PyImport_ImportModule("readline");    // line 215
if (mod == NULL) {
    PyErr_Clear();
}
else {
    Py_DECREF(mod);
}

Suggested changes:

PyObject *readline = PyImport_ImportModule("readline");
if (readline == NULL) {
    PyErr_Clear();
}
else {
    Py_DECREF(readline);
}

Let me know your thoughts.

New guy here,
Gerol