Dominik Vilsmeier writes:
Maybe people start writing code like this:
if not zip.checksame(a, b): raise ValueError() for stuff in zip(a, b):
At some point you just have to hope that people read documentation.
Maybe there's a better name; that one was originally chosen for a value of the length argument, and got moved to a class method on zip "as is". I guess you could go for something like "zip.while_asserting_same_length".