- `p[q]` joins path q to path p

For some obscure reason I really like this one. I can understand the arguments
against it though. So I'll probably be the only one to be +0 on this proposal.

- `p + q` joins path q to path p

-0
I agree with who says this operator should be used as suffix appending, and not
for path components. 

- `p / q` joins path q to path p

+0
I'm not against the div operator I'd prefer to use another one. I'm a *nix person but
I find this proposal too *nix-centric.

About the operator: I really like Steven D'Aprano's proposal: I find & just perfect.
I'm way more than +1 on it.

- `p.join(q)` joins path q to path p
 
+1
I feel the need for a method, in parallel with some operator. About the name: if join
is rejected I am:
    +1 on add()
    +1 on adjoin()
    +0 on append()
    -1 on pathjoin() / joinpath() -- too long, too similar, way too ugly.