On Fri, May 15, 2020 at 05:58:16AM -0400, Ricky Teachey wrote:
Perhaps use the iter function name as the generic? "itered". As opposed to "iterated" or "iterated over".
"the statement below iterates over an iterator, itered from a sequence"
Or just avoid the issue:
"The statement below iterates over a sequence"
which is perfectly valid and correct.
If we do feel the need to drill down into pedantic technical details, instead of making up ugly words that nobody will have any clue whatsoever what the meaning is, we could use one of many existing English words:
built from formed from constructed from made from fabricated from created from put together from
etc. And notice I avoided using terms which imply that the sequence itself is transformed into an iterator, such as "converting into".
 "Iter" is an old term for a passage, in particular an anatomical term for a passage in the brain, so "itered" would be the past tense of a verb to turn something into a passage.