On Thu, Jul 29, 2010 at 3:51 PM, Antoine Pitrou email@example.com wrote:
Le jeudi 29 juillet 2010 à 15:47 +0200, Tarek Ziadé a écrit :
On Thu, Jul 29, 2010 at 3:42 PM, Tarek Ziadé firstname.lastname@example.org wrote:
And I don't see how `__json__` is more annoying than e.g. `to_json`.
Its easier to override
Could you expand a little bit?
If you want to override to_json in a subclass, to slightly adapt it, its easier because the __json__ name is mangled by Python