July 28, 2014
6:37 p.m.
On Jul 28, 2014, at 11:04 AM, Steven D'Aprano <steve@pearwood.info> wrote:
I'm still inclined to prefer allowing update() to accept multiple arguments:
a.update(b, c, d)
rather than a += b + c + d
which suggests that maybe there ought to be an updated() built-in, Let the bike-shedding begin: should such a thing be spelled ?
new_dict = a + b + c + d
or, to match set new_dict = a | b | c | d