
14 Oct
2011
14 Oct
'11
7:23 p.m.
We've been bikeshedding long enough. I propose to do the following to range() in Python 3.3:
- add read-only attributes .start, .step, .stop - add slicing such that it normalizes .stop to .start + the right multiple of .step - add __eq__ and __hash__ which compare by .start, .step, .stop
And no more.
--
--Guido van Rossum (python.org/~guido)