On Sun Dec 29 2013 at 2:35:07 PM, Andrew Barnert <abarnert@yahoo.com> wrote:
I also love hard coding SDL 2.0.1 into your portable application, because there's no way they'll ever release a newer version without telling you in advance so you can forcibly update all your users, which makes their "latest" links useless.

Using a fixed version isn't necessarily a terrible idea. While lots of libraries strive for backwards compatibility, that doesn't mean they don't sometimes break it (intentionally or accidentally). Always pulling down the latest version of a library can lead to trickier debugging.