Hi Christopher

I did notice the unusual command line, but didn't think any more of it. I thought everything I needed to look at was already in the message.

A reference to https://pypi.org/project/importhook/ would have helped me. I don't see importhook providing a practical implementation of the original poster's request.

Going back to that, I don't see why something like
    a = Timer(time_consuming_function)()
shouldn't actually provide the semantics wanted for
    a = time_consuming_function()

My preference is for code that's easier to read rather than quicker to type. It's said that easy reading is hard writing.

I'm also reminded of Einstein's (or is it?) Everything Should Be Made as Simple as Possible, But Not Simpler.