On Tue, 2 Nov 2010 16:02:47 +0100 spir email@example.com wrote:
Imo, "timer" is exactly the proper term
I'm not sure it's the proper term. A timer is often a countdown with a callback. See for example threading.Timer and signal.setitimer.
the issue due to proximity with "time" is real, but far less important.
I think it would be too easy to use one instead of the other, and get strange semantics (both count in seconds but with slightly different characteristic).